Back
Maintenance

Moving our web wallet to https://wallet.oasis.io/
Completed 20 Apr at 01:00pm UTC.
Oasis Wallet - Web (wallet.oasis.io)
Completed
Maintenance completed
Posted
20 Apr at 01:00pm UTC.

Started
Hey everyone! Our web wallet is moving to a new domain! As our Docs and Forum are already on oasis.io, it only makes sense for our Wallet to be there as well. So starting Thursday, April 18th, 12:00 UTC you can find our web wallet over at https://wallet.oasis.io/. Previous domain, https://wallet.oasisprotocol.org/ will still function and redirect to the new domain.
Posted
20 Apr at 12:00pm UTC.